MSPSS: is there life after the helpdesk?

sharing solutions to uncommon IT problems

Posts Tagged ‘upgrade

DotNetNuke – Error during upgrade “A newer version of this package is already installed”

leave a comment »


Hello,

When I tried to upgrade our DNN portal from 7.1.2 to 7.2.0 I got a blocking, very cryptic error: “Upgrade A newer version of this package is already installed”.

The error log showed the following lines:

01/12/2014 17:55:09 [INFO] DotNetNuke.Services.Upgrade.Upgrade Start InstallPackage:D:\MyWebsite\Install\Module\DNNCE_CoreMessaging_07.00.04_Install.zip
01/12/2014 17:55:10 [ERROR] DotNetNuke.Services.Upgrade.Upgrade A newer version of this package is already installed – 7.1.2

The problem was that I had copied over the upgrade files without first deleting the old Install folder. In the install folder we had old modules alongside with the new modules.

Apparently the DNN Install/Upgrade routine tries to install all modules in the module folder without any particular order or rule. When it tried to install a very old version of the coremessanging module it prompted the error above.

Deleting the Install folder (best practice anyhow) fixes the problem.

HTH,
Roberto.

Advertisements

Written by zantoro

January 13, 2014 at 9:19 am

Posted in DotNetNuke

Tagged with ,